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WXtoImg is one of those strange programs that may at
first frighten the casual user but offers an impressive
performance for its price (free for the limited version).
I does most of what has to be done in automated APT
reception and processing, and does it very well indeed.
Some say I'm somewhat biased (or worse) towards
Linux, but I feel that somehow this operating system
reflects part of the radio amateur spirit. Do continue
reading - there’s a Windows version for the others too!

I freely admit that software offerings for Linux are
somewhat limited, not entirely unlike the recent
problems we have faced in electronic component
procurement. But generally, programs that are
available are of excellent quality, offer many options,
and are very reliable(and free, with source code!). A
case in point is the WXtoImgl?] program, which is
available on the Internet, both for Windows and Linux
(there’s also a MacOS version but it isn’t updated as
frequently).

WXtolmg comes in two forms; the ‘standard’ version
which is free, and which is the one I'm describing
below, and the ‘professional’ version, for which a low
registration fee is required. The latter adds several
projections, some processing options, and can even
automatically create and update web-pages with your
images. You can download WXtoImg from:

http://www.weather.net.nz/wxtoimg/index.html

Installing WXtoImg

Installing WXtoImg in Linux is easy—there’s just one
executable file. Copy xwxtoimg to /usr/local/bin
where the operating system will find it, and you're set.
(If you use Windows, then just double-click the
wxinstnnnn.exe file and installation is automatic,
complete with a desktop short-cut icon.)

There’s a command line version for Linux, which
permits execution of all reception and processing from
batch files (in fact, it consists of a suite of 5 command-
line programs: wxtoimg, wxrec, wxmap, wxproj, and
wxbatch, each of which does the task which its name
implies).

The most recent few versions display a nag screen
which waits for 10 seconds before enabling the rest of
the program. (Personally, I do not approve of this
method of trying to get the user to register. Still, you
will normally never stop the program, so it's not too
bad either). A stumbling block with Linux programs is
the sometimes more austere user interface. Some of
this is noticeable in WXtoIlmg.
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Figure 1 - Thumbnail page of recently decoded images

You can select from several options to start processing:
* Select an existing audio file

* Select what’s called a ‘raw image’
* Select ‘Record’

» WXtolmg: /root/20040
EIIEI Direction Satellitg

Open Audio File...
Open Raw Image...

Standby (waiting for a 2400 Hz
carrier) and reception take no
noticeable CPU resources and I
leave them running all the
time. Once an image has been
received, it takes the PC just a
few seconds to do the processing
and to generate the final image.
A new feature in the most

Save Image as...
Composite Image to...
Save Raw Image as...

recent versions of WXtolmg is oL
that they actually show the raw e
satellite image during | pecode
reception. Partial Decode...
Auto Process
Figure 6 (page 29) shows the
program after processing an | ¥iew Image...
audio file (or receiving a | View Movie...

satellite pass). Note the tabs Publish Weh Fage
above the image—this 1s | Image Properties...
another relatively new feature
and permits you to browse
through thumbnails of your
images (fig. 1), for example, or

Processing Info...
Update Keplers
Satellite Pass List...

to check which audio files are g_lear
still available: ‘% :
Exit
Available features
Figure 2

Let’s have a quick look at the
main menus, and discuss some of the possibilities.
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File Menu

In the File menu (fig.2) there are many
options , but the most frequently used will
probably be Open Audio File..., Save Image
as... and Record.... In most cases this will be
very straightforward. Under Linux, I prefer
to use the standard GTK gmixer ap-
plication, which I am more comfortable
with (I don’t like the aesthetics of
WXtolmg’s built-in mixer).

The use of most options is simple, as most of
the parameters (JPEG quality, recording
settings etc.) need only be programmed
once into the Options menu item.

The Direction Menu

The Direction item (fig.3) allows you to
select a satellite direction manually or to
leave WXtolmg to do this automatically for
you.

The Satellites Menu

The Satellite menu (fig.4) permits selecting
the satellite manually. This is useful if, for
some reason, the program gets confused by
very weak signals or strange schedules, or
older passes for which WXtoIlmg doesn’t
have orbital data stored.

The Enhancements Menu

Interesting though, are the enhancements
you can select. I haven’t seen another
program that permits so many excellent—
and different—algorithms for processing
the received imagery. For example, the ‘ZA’
infrared enhancement is excellent where
intense storms develop, as the normal IR
image tends to saturate in the white clouds.
The ZA remaps the intensities and nicely
shows the storms centres. Also useful is the
‘NO’ enhancement, which colours clouds
starting at -25°C or so, down to -90°C. We
had some very severe storms here in
Argentina a couple of months ago, and they
were very nicely rendered using this mode
(I even warned the local Civil Defence
authorities).

All the time, temperature at the cursor
position is available on the screen (except
for a bug, that stops the display of
temperature after saving a file—I've
notified the problem to the author). The
value corresponds quite well with reality.

The Options Menu

The Options menu (fig.8) is the most
complicated—I had never really considered
that the actual reception of images
depended on so many factors!
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Several items that are normally only used
when post-processing images, such as
despeckling, and sharpening are available.
The despeckling algorithm works fine on
removing shot-noise. I was originally very
sceptical about despeckling, after having
tried several algorithms on other programs,
but I must admit that the one implemented
in WXtoImg works very well!

Be careful when setting the level though.
While the default value of 2.0 works fine, 1
personally prefer to use 2.5. A value of 3.0
despeckles less while a setting of 1.0 is
basically useless—it modifies cloud detail
strongly and does not really improve the
image (you can check the effects of different
despeckle settings in fig.9)

Interpolate makes a brave try to
interpolate the video (or the audio) and
double the resolution. This succeeds in
some images but in others the image just
becomes larger without any noticeable
improvement. The Noise Filter works, but,
as expected also removes some of the
details of the image, which is really
unavoidable, I guess...

The Illumination Compensation again
makes a brave attempt to compensate for
predictable variations of light conditions in
the images. Though some images do
improve, in extreme cases the image gets
too noisy because of the increased gain
being applied.

Active APT Satellites lets you select, as
the name implies, the satellites for which
Kepler elements have to be fetched from the
Web, and which have to be monitored.
(WXtolmg downloads the data from the
Celestrak 11 website.

On the same menu, you can also program
the satellite’s frequency (to control a
receiver, for example), and to assign a
priority in case two satellites have
overlapping passes.

Ground Station Data is, as you would
expect, where you input your station
information (name, latitude and longitude),
though the registered version has the
possibility of synchronising with the NMEA
data stream from a GPS receiver (I use the
Internet to sync the PC’s clock and a
program called Chrony 181 which connects to
NTP servers, measures the PC’s crystal
frequency error and, using saved statistics,
is able to correct the clock should the
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Projection
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Figure 5
Projection menu
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Figure 7 - A two-pass composition of NOAA-17 multispectral analysis images
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Internet connection drops temp-
orarily.

Recording Options offers four
different methods for initiating
recording:

+ Start using WEFAX start tones

* Record when a 2400 Hz tone is
detected (with safeguards at the
beginning and end, the method
that I normally use)

* Record when the sound level
rises—nice if you have a
squelch implemented in your
receiver, preferably a tone-
activated squelch.

* Record when an APT satellite is
overhead. The program has its
own orbital prediction program
built-in, so 1t can activate the
receiver using those data. In my
particular location this system
is not very useful because I'm
actually living on the slope of a
rather steep hill; in some
directions I have a minimum
elevation of only 25° to 30°
while in other azimuths I can
actually receive the satellite till
it is under the horizon—this
defeats the minimum elevation
setting for me. To paint it
another way: I have only
sunsets, the sun rises well
behind the ‘mountain’.

Just one final option— it really goes
on and on—is Map Overlay, which
even permits you to select how the
maps are going to be overlaid on the
images, how detailed they’re going
to be and the colours and line widths
used to display boundaries, etc.

Projections

The projections menu (fig.5) is the
item that is most restricted from the
registered version, I guess. It offers
three projections:

+ Normal (as sent by the satellite)

* Equidistant cylindrical, a
projection which I particularly
have little use for

* And Eckert IV, which is a very
interesting one, as it permits
fairly easy combination of the
images from two consecutive
passes. In fact, in the registered
version, this combination can be
done automatically.
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The registered version offers a lot of
other projections, some of which
seem interesting, other less so.

Image

The image menu really contains a
lot of things I'd rather leave to a
paint program. But then WXtoImg
is targeted as a ‘do-it-all’ program
that does everything from reception
to publishing, so any post-
processing enhancement has to
provided too. The only two items I
ever use are the Move Map Overlay
(rarely, if for some reason the
Internet connection breaks down
and the map slips in the image) and
even more infrequently, the Magnify
Area option, to look at an
enlargement of part of an image. It’s
often interesting to observe the
Enhancement Curves though.

Help

The Help menu does just that, and
quite well. It has several chapters
on the different aspects of the
normal use of WXtoImg, and also
provides help for the command line
version (which might otherwise
prove rather tricky). Help also has
the tools to register the program and
to enable the features unavailable
(greyed-out) in the unregistered

version. I can wvouch for the
development activity on the
program. Though I haven’t

registered yet (I plan to do so real
soon now). I have sent the author
details of a few problems and always
had a helpful reply.

Some Final Musings

WXtoImg is performing excellently
here. So much so I have pretty well
archived the processing program I
wrote a few years ago. The splash
screen with the 10 seconds delay
bugs me a little, particularly as it
wasn’t there in previous versions.
On the other hand, the program
runs here for weeks on end, so it
does not make me suffer too much.

As a free program, the relation
between performance and price
would probably be acceptable, but in
a Linux world where most programs
are free, performance is normally
judged separately—and WXtoImg
scores very well indeed.
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Figure 8
Options menu

Figure 9
Despeckle Options
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